This issue, which has affected many popular websites like Spotify, Twitch, Stack Overflow, GitHub, Hulu, HBO Max, Quora, PayPal, Vimeo, Shopify, Stripe, and news outlets CNN, The Guardian, The New York Times, BBC, and Financial Times, seems to be resolved
Posted Jun 08, 2021 - 14:11 CEST
Monitoring
The issue has been identified by Fastly and a fix has been applied.
Posted Jun 08, 2021 - 12:58 CEST
Update
Our partner updated their status with the following note: "The issue has been identified and a fix is being implemented." We continue to monitor the situation that seems to affect huge parts of the internet.
Posted Jun 08, 2021 - 12:56 CEST
Investigating
We're currently experiencing interruptions with the login flows to join.pitcher.com meetings
This is an infra incident that originates from our provider Google Firebase which in turn depends on Fastly (which is currently down) - https://status.fastly.com/.
We'll be closely monitoring the situation and update here.